Jump to content

Important security notification for server owners and hosters


Recommended Posts

On 20/05/2022 at 10:22, Sensacion said:
/lib64/libc.so.6 version glibc_2.25' not found centos 7

Error for Centos 7, glibc version.

Same bug on Ubuntu 16.04

 

MTA:BLUE Server for MTA:SA

/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.25' not found (required by /home/tcagame_svc2699/4evergaming/2699/x64/deathmatch.so)

ERROR: Loading mod (/home/tcagame_svc2699/4evergaming/2699/x64/deathmatch.so) failed!
Press Q to shut down the server!

 

Link to comment
Posted (edited)
On 21/5/2022 at 17:41, 4evergaming said:

Same bug on Ubuntu 16.04

 

MTA:BLUE Server for MTA:SA

/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.25' not found (required by /home/tcagame_svc2699/4evergaming/2699/x64/deathmatch.so)

ERROR: Loading mod (/home/tcagame_svc2699/4evergaming/2699/x64/deathmatch.so) failed!
Press Q to shut down the server!

 

Surely it is because of your version of VPS, in my case I did not have any problem, the update works very well for me.
I am using ubuntu 18.04

Edited by BranD
+info
Link to comment
  • MTA Anti-Cheat Team

It's not bugs.. the glibc errors are because MTA server no longer supports some very outdated Linux distributions.

The solution is simple, update Linux. Using old versions is a bad practise, and can even present security risks. There is no reason to, say, use Ubuntu 16.04 (no longer supported).

Any server owner or hoster that wants to be able to use new versions of MTA in the future, has to update their Linux distribution. If you don't know how to, ask any friend that has experience with Linux.

 

* Referred to this:

On 20/05/2022 at 13:22, Sensacion said:
/lib64/libc.so.6 version glibc_2.25' not found centos 7

Error for Centos 7, glibc version.

 

On 21/05/2022 at 21:41, 4evergaming said:

Same bug on Ubuntu 16.04

 

MTA:BLUE Server for MTA:SA

/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.25' not found (required by /home/tcagame_svc2699/4evergaming/2699/x64/deathmatch.so)

ERROR: Loading mod (/home/tcagame_svc2699/4evergaming/2699/x64/deathmatch.so) failed!
Press Q to shut down the server!

 

@4evergaming Ubuntu 16.04 was released in 2016 and went out of LTS support in 2021. Just upgrade to Ubuntu 22.04 to solve the problem.

 

* For anyone that cares.. after the OVH fire incident we had to rebuild our Linux build agents, losing support for some ancient Linux distro versions. It's not worth the effort to bring it back and maintain it. We also phased out older platforms like Windows XP in a similar manner.. there always comes a point where we need to encourage users to update their system rather than maintaining compatibility with legacy systems (which can complicate adding new features and improvements)

Link to comment
  • 1 month later...
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...