Jump to content

Patching your invalid gta3.exe or gta-vc.exe

Recommended Posts

MTA does not function at all with German or Australian versions of gta3.exe and gta-vc.exe. This patcher will modify your existing .exe to work with MTA.

I am sure this is legitimate, there is not enough data in the .exe to extract the full gta-vc.exe. If a moderator/dev finds that this patcher somehow provides the entire executable file, remove the link and inform me.




This patch does NOT turn your gta3.exe or gta-vc.exe into a version that requires no CD, but converts your gta3.exe or gta-vc.exe from German or Australian INTO the American/European version. Please make backups of the respective file in case something goes wrong. I am not responsible for damaged or lost files.

For this to work you must have one of the following:

* GTA3.exe German Version

* GTA3.exe Australian Version

* GTA-VC.exe German Version

* GTA-VC.exe Australian Version

If you get an "Invalid Executable" error for GTA3 please download the 1.1 patch before posting, from here: http://updates.rockstargames.com/patches/grandtheftauto3/GTA3patch1.1.zip. If you are still getting problems for GTA3 and are from Australia or Germany please post in this topic to help.

Thank you to "Pain" for providing the German gta-vc.exe and "Gremlin Gremlin" for the Australian gta-vc.exe, and vicer for his help.

I hope this helps.


Edited by Guest
Link to comment

Yeah good idea Talidan, we've had heaps and heaps of newbies come into the servers in Australia, most of them don't have a clue what is going on when they see that error or their game crashes just after it plays the VC movie. It would be a lot easier if they knew from scratch what is going on instead of having to ask everyone first, so maybe a link to the working exe or something would be handy in a place everyone can see before they bother starting the game instead of having to search up on why it won't work.

Link to comment
  • 4 weeks later...

i have gta 3 1.1 and i still get the damn error.

ive tried uninstalling and reinstalling multiple times.

wiped everything out and still the error proceeds.

im not sure how to tell if my copy is american or not.

but it wont run.

please help.

Link to comment

Then can anyone help me? it says 60% of all probelms can be fixed by patching GTa-vc but whenevr i try to patch, it syays my gta-vc.exe is an unknown version.

Link to comment
  • 4 weeks later...
okay ive uploaded it at a temp new host. could you also remove the long quote in your post, it contains the old download link and could be misleading, and is a little spammy

Thanx, i hope i can play with our patch =)

€dit: i got the error message "unkown Version" whats meaning? :/

Link to comment
  • 1 month later...
  • 1 month later...

Thank you so much. I was so dissapointed when it came up with the error when I first tried. I have a small suggestion, link to this post on the known issues post, then the next Australian with this problem won't have to spend 20 minutes searching Google :P

Link to comment
  • 5 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...