Jump to content

Libncursesw.so.5: cannot open shared object file:


Recommended Posts

Hello, i recently got vps with Ubuntu 19.04 and i have successfully installed OGP in it. When i started MTA server x64 using it, I got following error in log file:

libncursesw.so.5: cannot open shared object file: No such file or directory
ERROR: Could not load ./x64/core.so
* Check installed data files.
Press enter to continue...

I checked google for all possible fixes but still i am getting this issue. I have already installed that required lib but its not helping at all. I also have installed 32 bit libraries, tried to install ncurses manually but same issue. Kindly help me with it.

Link to comment

Ok, from that ldd command i figured out i was still missing 32 bit libraries of libncurses. Since its ubuntu 19 so it is not possible to install them using apt-get install command directly. Although i installed it manually but yet i was missing them somehow. When i did apt-get install lib32ncurses, i couldn't get the package.
So i fixed it with following commands from a guide i found just now:

sudo dpkg --add-architecture i386 
sudo apt-get update 
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386 lib32z1

Thanks for your support. You may close the thread now thanks.

Link to comment
  • 7 months later...
Good afternoon, I also have the same problem with a VPS that I buy.

libncursesw.so.5: cannot open shared object file: no
such file or directory exists ERROR: Could not load ./x64/core.so
* Verify the installed data files.
Press Enter to continue ...

Using the steps given by Mubeen I could not solve my problem, can you help me?

 

Link to comment
  • 5 months later...

Hi, took me a while to get in touch with this post.
With newer versions of Ubuntu, this problem seems more complicated. Problem is that you already have libncurses.so.5 but it is not recognized by the system. Easy way to fix it is to run the following command:
sudo apt-get install -y libncursesw

 

  • Like 2
Link to comment
  • 10 months later...

Hello faced with such a problem
I use Linux Manjaro KDE Plasma from 12/14/2021
I tried to install the necessary libraries
, some of them were installed and the other was not
used (sudo pacman -S libncurses5-dev libncursesw5-dev )
And says that the package was not found

 

 

------ sudo pacman -------------------------

mistake: target not found: libncurses5-dev

mistake: target not found: libncursesw5-dev

PjKcS.png

 

 

 

 

--------------------- Error Compiling------------------------------------------------------

/usr/bin/ld: cannot be found -l:libncursesw.so.5
collect2: error: ld execution ended with return code 1
make[1]: *** [Core.make:208: ../Bin/server/x64/core.so] Error 1
make: *** [Makefile:161: Core] Error 2
make: exit from the directory "/home/skynet/Downloads/mtasa-blue-master/Build"

--------------------- Error Compiling------------------------------------------------------

PjKOz.png

PjKg0.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...