Jump to content
  • 0



Hello everyone, I'm having problems with the `mta sa` client ...

When I installed the MTA and try to open it it gives me the following message:

MTA: San Andreas  [CN01]   (CTRL+C to copy)
There was a problem validating your serial


Moderator edit (knownledgebase note): If you're getting the error "CN01: There was a problem validating your serial" then you need to:

follow the instructions at https://updatesa.multitheftauto.com/sa/trouble/?tr=serial-validation

For example, if you're on Windows, these would be the extended steps for instruction 1) at the link above

- Run MTA on the host system atleast once, so without VMware on the same PC.

- Then use VM(ware) to use MTA again, after doing that.

Reason: MTA wants to generate your MTA serial on the 'real' PC, so it can restore your original MTA serial into your VM. This is a technical measure to stop people from ban evading & easy serial changing with VM's.

So long story short, you just need to use MTA without VM one time, and then you can keep using VM forever. Your PC cannot "first meet" MTA while running through a VM.

If you're on Linux, the Linux MTA server contains an alternative to complete the same process; use instruction 2 from the link.



I can open gta-sa normally...

Someone can help me?

Ps: I forgot, I'm using a virtual machine (VMWARE)

Link to comment

6 answers to this question

Recommended Posts

  • 0
1 hour ago, ccw said:

What happens when you press 'OK' ?

Opens a site with these instructions:


But i found a bug when i tried this.

1 - Desactive internet from your Linux (So that your virtual machine does not have internet)

2 - Open your server in linux with root

3 - Open your mta-client in vm

4 - Then the MTA will not check your serial and will open.

5 - Play it


(You can let your IP from virtual machine invalid for use only local)

Works only on local servers.






If you activate internet  then MTA crashes



Link to comment
  • 0
6 hours ago, ccw said:

Please start the Linux server again.


I tried this:

1 - Open Linux Server

2 - Try enter MTA client...

But when I open the Linux server and open the client on the VM, same thing happens.

Edited by Iaan
Link to comment
  • 0
6 hours ago, ccw said:

Does the MTA Linux server have full internet access?

What server IP is shown in the server log:

Querying MTA master server... success! (Auto detected IP:?????)


Before,IP is not shown, now i tried and successful.
1 - Open the linux-server and wait for IP
2 - Open client in VM
Thanks for support, bro.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...