Jump to content

[SERVER] Download Error 9 (SOLVED/BE FIXD IN DP3)


Recommended Posts


Alright, where to start. This might be a long read, but bear with me. It all started back in DP1, I was finding when the client was downloading files from the server (client side script files), it usually went quite slow. Soon after this, I found the httpdownloadurl and I decided to start using it. This is where the trouble began. I put the address in, made sure all the files were unzipped to their own folders with the correct folder names and that everything was accessible publicly via my webserver. Everything was a go. So i restarted the server, joined, and voila, no problems. Soon after this I was noticing many players joining, then disconnecting after about 2-3 seconds. I got intouch with these players and they all were reporting a download error 9. So, I thought to myself how they could be getting the download error, and I couldnt be getting that error. The reason they were getting the error and I wasn't is because I already had all of the client files downloaded from before I set the httpdownloadurl in. So i went into my client mtasadm folder and found the folder resources. I deleted that folder, started up the game and joined. And, just as i predicted, download error 9. I did a little investigation into this issue, but not much because i really thought it was a bug with mta, seeing how this was the first release. Please note, everything worked fine without the httpdownloadurl.

So now DP2 comes around, and I am very excited to see if the httpdownloadurl bug was fixed. I got everything ready, set what had to be set, uploaded what had to be uploaded and started the server. I made sure my clients resources was empty, so i would redownload all the resources needed from the httpdownloadurl that was set in the server. I join the server, and..download error 9. I screamed in agony and pain. So, i decided to do some trial and error (the last option..oh god). I wanted to make sure 100% this was not a mistake of mine. Below is the semi long list of stuff i checked to make sure it was not a mistake of mine.

- Made sure all files were there and unzipped in their seperate folders

- Made sure (On my linux webserver) permissions were set correctly on ALL files and folders

- Made sure in the httpdownloadurl section of my mtaserver.conf that i had the url without the trailing slash

- Made sure the slash's were the correct direction

- Made sure everything was spelt correctly

- Read the wiki for this, and made sure everything met the requirements

- Did quite a bit more, but can't remember at this time

I then decided to go deeper in the trial and error, and to test it on one of my windows web servers. Who knows, maby it was Linux acting up with permissions, apache or something of that manner. So, went through the above checklist, one my one, made sure nothing was wrong. Connected, 2 seconds later, download error 9. From the investigation I did with DP1, i located it to be the admin resource, but I cannot confirm this, becuase with DP2, any resource client file download gives that error when httpdownloadurl is set.

So now I am really desperate (spent quite a few hours on this, and wanted to find a way to fix it), and started talking to lil_toady. He gave me some pointers all stated in the above list. Nothing worked. Then he redirected me to http://curl.haxx.se/libcurl/c/libcurl-errors.html and to look under 'CURLE_REMOTE_ACCESS_DENIED (9)'. So I did, and it says there the following;

We were denied access to the resource given in the URL. For FTP, this occurs while trying to change to the remote directory.

This was not the problem. I tested many times to make sure everything was accessible publicly. Ontop of that, I tested on many web servers, all in different locations around the world. So, any pointers towards fixing this problem would be greatly apprecitated. Or if this is a bug, if you could look into it for the next release, I am sure many others would really appreciate it, not only me.

Sorry for the long message and thanks for your time.



Edited by Guest
Link to comment
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...