Jump to content

Moony

Recommended Posts

Estoy siguiendo este tutorial.

Al momento, tengo esto:

Spoiler
function createLoginWindow ()
	-- define position of window (decimals con with a period)
	local X = 0.375
	local Y = 0.375
	-- define widght and height of window
	local Width = 0.25
	local Height = 0.25
	wdwLogin = guiCreateWindow( X, Y, Width, Height, "Loguear", true)
	
	X = 0.0825
	Y = 0.2
	Width = 0.25
	Height = 0.25
	guiCreateLabel ( X, Y, Width, Height, "Usuario", true, wdwLogin)
	Y = 0.5
	guiCreateLabel ( X, Y, Width, Height, "Contraseña" true, wdwLogin)
	
	X = 0.415
	Y = 0.2
	Width = 0.5
	Height = 0.15
	guiCreateEdit ( X, Y, Width, Height, "", true, wdwLogin)
	Y = 0.5
	guiCreateEdit ( X, Y, Width, Height, "", true, wdwLogin)
	
	X = 0.415
	Y = 0.7
	Width = 0.25
	Height = 0.2
	guiCreateButton ( X, Y, Width, Height, "Ingresar", true, wdwLogin)	
	
	guiSetVisible (wdwLogin, true)
	
	
end

 

El script está ubicado dentro de una carpeta ("client"), y el archivo se llama "gui.Lua". El meta.xml está editado de tal manera que vaya a buscar el script a cliente/gui.Lua.

He reducido el script a elementos más simples para testear las partes. Al momento, solo tengo habilitada la ventana; todo el resto está removido.
No funciona. No tengo errores en la consola, pero tampoco tengo una ventana en el juego.

¿Es posible que el tutorial tenga errores o esté desactualizado? ¿El error lo estoy cometiendo yo? ¿Cómo lo puedo arreglar?

Descubrí que tengo muchos errores y elementos faltantes.
No pude encontrar alguna función para eliminar el post.

Edited by Moony
Optimización.
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...